Skip to content

Commit

Permalink
Merge branch 'rmandrad:main' into main
Browse files Browse the repository at this point in the history
  • Loading branch information
N-Storm authored Oct 1, 2024
2 parents 90794bb + c78c71a commit 7ba16cb
Show file tree
Hide file tree
Showing 7 changed files with 13 additions and 2 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>

--- a/net/mac80211/sta_info.c
+++ b/net/mac80211/sta_info.c
@@ -2455,6 +2455,13 @@ static void sta_stats_decode_rate(struct
@@ -2439,6 +2439,13 @@ static void sta_stats_decode_rate(struct

sband = local->hw.wiphy->bands[band];

Expand Down
3 changes: 2 additions & 1 deletion package/kernel/mt76/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -661,6 +661,7 @@ define KernelPackage/mt7992-firmware/install
cp \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_dsp.bin \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_eeprom.bin \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_eeprom_2i5i.bin \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_rom_patch.bin \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_wa.bin \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_wm.bin \
Expand All @@ -672,7 +673,7 @@ define KernelPackage/mt7992-23-firmware/install
cp \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_dsp_23.bin \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_eeprom_23.bin \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_eeprom_23.bin \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_eeprom_23_2i5i.bin \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_rom_patch_23.bin \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_wa_23.bin \
$(PKG_BUILD_DIR)/firmware/mt7996/mt7992_wm_23.bin \
Expand Down
10 changes: 10 additions & 0 deletions tools/elfutils/patches/100-portability.patch
Original file line number Diff line number Diff line change
Expand Up @@ -288,3 +288,13 @@

/* Definitions of arguments for argp functions. */
static const struct argp_option options[] =
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -92,6 +92,7 @@ strings_LDADD = $(libelf) $(libeu) $(arg
ar_LDADD = libar.a $(libelf) $(libeu) $(argp_LDADD) $(obstack_LIBS)
unstrip_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD)
stack_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD) $(demanglelib)
+EXTRA_stack_DEPENDENCIES = $(if $(findstring srcfiles,$(bin_PROGRAMS)),$(srcfiles_OBJECTS))
elfcompress_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD)
elfclassify_LDADD = $(libelf) $(libdw) $(libeu) $(argp_LDADD)
srcfiles_SOURCES = srcfiles.cxx

0 comments on commit 7ba16cb

Please sign in to comment.