Skip to content

Commit

Permalink
Merge pull request #18 from MistySOM/develop
Browse files Browse the repository at this point in the history
Develop->Master
  • Loading branch information
matinlotfali authored Mar 12, 2023
2 parents 6f64230 + 253b1b8 commit 7211c72
Show file tree
Hide file tree
Showing 34 changed files with 866 additions and 24 deletions.
4 changes: 1 addition & 3 deletions recipes-core/images/mistysom-image.bb
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
SUMMARY = "MistySOM image."

IMAGE_FEATURES += "splash package-management ssh-server-dropbear hwcodecs packagegroup-core-boot ${CORE_IMAGE_EXTRA_INSTALL}"
IMAGE_FEATURES += "splash package-management ssh-server-dropbear hwcodecs"

LICENSE = "MIT"

Expand All @@ -18,5 +18,3 @@ REQUIRED_DISTRO_FEATURES = "wayland"
# usermod -P 'toor' root \
# "

CORE_IMAGE_BASE_INSTALL += "weston weston-init weston-examples gtk+3-demo clutter-1.0-examples"
CORE_IMAGE_BASE_INSTALL += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'weston-xwayland matchbox-terminal', '', d)}"
56 changes: 56 additions & 0 deletions recipes-core/images/mistysom-image.bbappend
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
CORE_IMAGE_BASE_INSTALL += "pv htop kernel-modules weston weston-init weston-examples gtk+3-demo clutter-1.0-examples"
CORE_IMAGE_BASE_INSTALL += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'weston-xwayland matchbox-terminal', '', d)}"
IMAGE_INSTALL_append = " python3"
IMAGE_INSTALL_append = " python3-datetime"
IMAGE_INSTALL_append = " python3-io"
IMAGE_INSTALL_append = " python3-core"
IMAGE_INSTALL_append = " python3-multiprocessing"
IMAGE_INSTALL_append = " usbutils"
IMAGE_INSTALL_append = " usbutils-python"
IMAGE_INSTALL_append = " phytool"
IMAGE_INSTALL_append = " ethtool"
IMAGE_INSTALL_append = " can-utils"
IMAGE_INSTALL_append = " libsocketcan"
IMAGE_INSTALL_append = " iproute2"

# For Camera
IMAGE_INSTALL_append = " i2c-tools"
PACKAGECONFIG_append_pn-libgpiod = " python3"
IMAGE_INSTALL_append = " libgpiod libgpiod-tools"
IMAGE_INSTALL_append = " v4l-utils"
IMAGE_INSTALL_append = " v4l-utils-dev"
IMAGE_INSTALL_append = " v4l2-init"
IMAGE_INSTALL_append = " v4l2-init-dev"
IMAGE_INSTALL_append = " libv4l"
IMAGE_INSTALL_append = " libv4l-dev"
IMAGE_INSTALL_append = " yavta"
IMAGE_INSTALL_append = " yavta-dev"
IMAGE_INSTALL_append = " gstreamer1.0"
IMAGE_INSTALL_append = " gstreamer1.0-dev"
IMAGE_INSTALL_append = " gst-examples"
IMAGE_INSTALL_append = " gstreamer1.0-plugins-base"
IMAGE_INSTALL_append = " gstreamer1.0-plugins-good"
IMAGE_INSTALL_append = " gstreamer1.0-plugins-bad"
IMAGE_INSTALL_append = " gstreamer1.0-plugins-ugly"
IMAGE_INSTALL_append = " gstreamer1.0-rtsp-server"

# For Hardware Acceleration and Video Codecs
IMAGE_INSTALL_append = " gstreamer1.0-plugin-vspmfilter"
IMAGE_INSTALL_append = " gstreamer1.0-omx"
IMAGE_INSTALL_append = " omx-user-module"
IMAGE_INSTALL_append = " mmngrbuf-user-module kernel-module-mmngrbuf"
IMAGE_INSTALL_append = " mmngr-user-module kernel-module-mmngr"
IMAGE_INSTALL_append = " vspmif-user-module kernel-module-vspm kernel-module-vspmif"

# For Wifi
IMAGE_INSTALL_append = " iw"
IMAGE_INSTALL_append = " dhcpcd"
IMAGE_INSTALL_append = " wpa-supplicant"
# WiFi Module Archer T2UH
IMAGE_INSTALL_append = " linux-firmware-mt7650"
IMAGE_INSTALL_append = " kernel-module-mt76x0u"
# WiFi Module Archer T2U Plus
IMAGE_INSTALL_append = " kernel-module-rtl8821au"

# For eMMC flashing
IMAGE_INSTALL_append = " e2fsprogs"
28 changes: 28 additions & 0 deletions recipes-drpai/gstreamer1.0-drpai/gstreamer1.0-drpai.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
SUMMARY = "GStreamer DRP-AI plugin"
SECTION = "multimedia"
LICENSE = "MIT"
SRC_URI = "git://github.com/MistySOM/gstreamer1.0-drpai.git;branch=master"
SRCREV = "${AUTOREV}"
LIC_FILES_CHKSUM = "file://COPYING.MIT;md5=bba6cdb9c2b03c849ed4975ed9ed90dc"
MESON_BUILDTYPE = "release"

inherit meson

DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base drpai"

S = "${WORKDIR}/git"
PV = "1.0"

do_install_append() {
install -d ${D}${ROOT_HOME}/yolov2
install -m 0755 ${S}/models/yolov2/* ${D}${ROOT_HOME}/yolov2
}

FILES_${PN} = "${libdir}/gstreamer-1.0/libgstdrpai.so ${ROOT_HOME}/yolov2"
FILES_${PN}-dev = "${libdir}/gstreamer-1.0/libgstdrpai.la"
FILES_${PN}-staticdev = "${libdir}/gstreamer-1.0/libgstdrpai.a"
FILES_${PN}-dbg = " \
${libdir}/gstreamer-1.0/.debug \
${prefix}/src"

RDEPENDS_${PN} = "gstreamer1.0 gstreamer1.0-plugins-base kernel-module-udmabuf"
13 changes: 0 additions & 13 deletions recipes-example/example/example_0.1.bb

This file was deleted.

25 changes: 25 additions & 0 deletions recipes-kernel/linux/Kconfigs/CANBUS.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
#
# CANbus support
#
CONFIG_CAN=y
CONFIG_CAN_RAW=y
CONFIG_CAN_BCM=y
CONFIG_CAN_GW=y
#CONFIG_CAN_VCAN=y
CONFIG_CAN_DEV=y
CONFIG_CAN_CALC_BITTIMING=y
CONFIG_CAN_RCAR=y
CONFIG_CAN_RCAR_CANFD=y
CONFIG_CAN_DEBUG_DEVICES=y
#
# Additional kernel config items needed for iproute2 and SocketCAN
#
CONFIG_NETFILTER_NETLINK=y
CONFIG_NETFILTER_NETLINK_QUEUE=y
CONFIG_NETFILTER_NETLINK_LOG=y
CONFIG_NF_CT_NETLINK=y
CONFIG_SCSI_NETLINK=y
CONFIG_IP_ADVANCED_ROUTER=y
CONFIG_NET_SCH_INGRESS=y
CONFIG_NET_SCHED=y

14 changes: 14 additions & 0 deletions recipes-kernel/linux/Kconfigs/FB_UDL.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
CONFIG_FIRMWARE_EDID=y
CONFIG_FB_FOREIGN_ENDIAN=y
CONFIG_FB_BOTH_ENDIAN=y
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_SYS_FILLRECT=y
CONFIG_FB_SYS_COPYAREA=y
CONFIG_FB_SYS_IMAGEBLIT=y
CONFIG_FB_SYS_FOPS=y
CONFIG_FB_DEFERRED_IO=y
# CONFIG_FB_BIG_ENDIAN is not set
# # CONFIG_FB_LITTLE_ENDIAN is not set
# # CONFIG_FB_MODE_HELPERS is not set
# CONFIG_FB_TILEBLITTING=y
# CONFIG_FB_SIMPLE=y
4 changes: 4 additions & 0 deletions recipes-kernel/linux/Kconfigs/GPIO.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
CONFIG_GPIOLIB=y
CONFIG_PINCTRL=y
CONFIG_PINCTRL_RZG2L=y
CONFIG_GPIO_SYSFS=y
1 change: 1 addition & 0 deletions recipes-kernel/linux/Kconfigs/GT9271.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
CONFIG_TOUCHSCREEN_GOODIX=y
1 change: 1 addition & 0 deletions recipes-kernel/linux/Kconfigs/RTL8152.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
CONFIG_USB_RTL8152=y
1 change: 1 addition & 0 deletions recipes-kernel/linux/Kconfigs/SX150.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
CONFIG_PINCTRL_SX150X=y
2 changes: 2 additions & 0 deletions recipes-kernel/linux/Kconfigs/TLV320AIC23.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
CONFIG_SND_SOC_TLV320AIC23=y
CONFIG_SND_SOC_TLV320AIC23_I2C=y
4 changes: 4 additions & 0 deletions recipes-kernel/linux/Kconfigs/USB_GADGET.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
CONFIG_USB_STORAGE_DEBUG=y
CONFIG_USB_GADGET_DEBUG=y
CONFIG_USB_GADGET_VERBOSE=y
CONFIG_USB_GADGET_DEBUG_FILES=y
1 change: 1 addition & 0 deletions recipes-kernel/linux/Kconfigs/VSC8531.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
CONFIG_MICROSEMI_PHY=y
20 changes: 20 additions & 0 deletions recipes-kernel/linux/Kconfigs/WIRELESS.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
CONFIG_MT76x0U=m
CONFIG_CFG80211=m

CONFIG_MAC80211=y
CONFIG_NETDEVICES=y
CONFIG_WLAN=y
CONFIG_WLAN_VENDOR_MEDIATEK=y

CONFIG_BT=y
CONFIG_NET=y
CONFIG_WIRELESS=y
CONFIG_NETDEVICES=y

CONFIG_USB=y
CONFIG_USB_ARCH_HAS_HCD=y
CONFIG_USB_SUPPORT=y
CONFIG_HAS_IOMEM=y

CONFIG_NO_IOMEM=n
CONFIG_S390=n
31 changes: 29 additions & 2 deletions recipes-kernel/linux/linux-renesas_%.bbappend
Original file line number Diff line number Diff line change
@@ -1,2 +1,29 @@
FILESEXTRAPATHS_prepend := "${THISDIR}:"
SRC_URI += "file://0001-add-vsc8531-userspace-dts.patch"
# Uncomment any patches here for which you wish to enable specific features for hardware testing
FILESEXTRAPATHS_prepend := "${THISDIR}/smarc-rzg2l:"
#SRC_URI += "file://0001-add-vsc8531-userspace-dts.patch"
#SRC_URI += "file://0002-add-sx150x-port-expander-dts.patch"
#SRC_URI += "file://0003-add-gpio-header-40-pin-dts.patch"
#SRC_URI += "file://0004-add-RSPI0-port-to-40-pin-header.patch"
#SRC_URI += "file://0005-add-scif2-serial-port-for-uart-testing.patch"
#SRC_URI += "file://0006-add-riic1-i2c1-for-testing-i2c-on-hdr.patch"
#SRC_URI += "file://0007-add-can-ports.patch"
FILESEXTRAPATHS_prepend := "${THISDIR}/smarc-rzv2l:"
#SRC_URI += "file://0008-add-vsc8531-userspace-dts.patch"
#SRC_URI += "file://0009-add-sx150x-port-expander-dts.patch"
#SRC_URI += "file://0010-add-gpio-header-40-pin-dts.patch"
#SRC_URI += "file://0011-add-RSPI0-port-to-40-pin-header.patch"
#SRC_URI += "file://0012-add-scif2-serial-port-for-uart-testing.patch"
#SRC_URI += "file://0013-add-riic1-i2c1-for-testing-i2c-on-hdr.patch"
#SRC_URI += "file://0014-add-can-ports.patch"

FILESEXTRAPATHS_prepend := "${THISDIR}/Kconfigs:"
SRC_URI += "file://CANBUS.cfg"
SRC_URI += "file://FB_UDL.cfg"
SRC_URI += "file://GPIO.cfg"
SRC_URI += "file://GT9271.cfg"
SRC_URI += "file://RTL8152.cfg"
SRC_URI += "file://SX150.cfg"
SRC_URI += "file://TLV320AIC23.cfg"
SRC_URI += "file://USB_GADGET.cfg"
SRC_URI += "file://VSC8531.cfg"
SRC_URI += "file://WIRELESS.cfg"
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
diff --git a/r9a07g044l2-smarc.dts.orig b/r9a07g044l2-smarc.dts
index bc2af6c..82ba67e 100644
--- a/arch/arm64/boot/dts/renesas/r9a07g044l2-smarc.dts
+++ b/arch/arm64/boot/dts/renesas/r9a07g044l2-smarc.dts
@@ -11,8 +11,32 @@
#include "rzg2l-smarc-pinfunction.dtsi"
#include "rz-smarc-common.dtsi"
#include "rzg2l-smarc.dtsi"
+#include <dt-bindings/net/mscc-phy-vsc8531.h>

/ {
model = "Renesas SMARC EVK based on r9a07g044l2";
compatible = "renesas,smarc-evk", "renesas,r9a07g044l2", "renesas,r9a07g044";
};
+
+&eth0 {
+ phy0: ethernet-phy@7 {
+ compatible = "ethernet-phy-ieee802.3-c45";
+ reg = <7>;
+ vsc8531,vddmac = <1800>;
+ vsc8531,edge-slowdown = <0>;
+ vsc8531,led-0-mode = <VSC8531_LINK_1000_ACTIVITY>;
+ vsc8531,led-1-mode = <VSC8531_LINK_100_ACTIVITY>;
+ };
+};
+
+&eth1 {
+ phy1: ethernet-phy@7 {
+ compatible = "ethernet-phy-ieee802.3-c45";
+ reg = <7>;
+ vsc8531,vddmac = <1800>;
+ vsc8531,edge-slowdown = <0>;
+ vsc8531,led-0-mode = <VSC8531_LINK_1000_ACTIVITY>;
+ vsc8531,led-1-mode = <VSC8531_LINK_100_ACTIVITY>;
+ };
+};
+
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
diff --git a/r9a07g044l2-smarc.dts.orig b/r9a07g044l2-smarc.dts
index bc2af6c..a6ff8c4 100644
--- a/arch/arm64/boot/dts/renesas/r9a07g044l2-smarc.dts
+++ b/arch/arm64/boot/dts/renesas/r9a07g044l2-smarc.dts
@@ -16,3 +16,35 @@
model = "Renesas SMARC EVK based on r9a07g044l2";
compatible = "renesas,smarc-evk", "renesas,r9a07g044l2", "renesas,r9a07g044";
};
+
+&i2c3 {
+ i2c_gpio_expander@20 {
+ #gpio-cells = <2>;
+ #interrupt-cells = <2>;
+ compatible = "semtech,sx1502q";
+ reg = <0x20>;
+ gpio-controller;
+ pinctrl-names = "default";
+ pinctrl-0 = <&gpio1_cfg_pins>;
+ gpio1_cfg_pins: gpio1-cfg {
+ pins = "gpio1";
+ bias-pull-up;
+ };
+ };
+ i2c_gpio_expander@21 {
+ #gpio-cells = <2>;
+ #interrupt-cells = <2>;
+ compatible = "semtech,sx1502q";
+ reg = <0x21>;
+ gpio-controller;
+ pinctrl-names = "default";
+ pinctrl-0 = <&gpio2_cfg_pins>;
+ gpio2_cfg_pins: gpio2-cfg {
+ pins = "gpio2";
+ bias-pull-up;
+ };
+ };
+};
+
+
+
Loading

0 comments on commit 7211c72

Please sign in to comment.