Skip to content

Commit

Permalink
Merge pull request #237 from Dasharo/develop
Browse files Browse the repository at this point in the history
Release 2.2.1
  • Loading branch information
m-iwanicki authored Feb 6, 2025
2 parents 7e30877 + f0e6333 commit 16d4fa0
Show file tree
Hide file tree
Showing 8 changed files with 50 additions and 10 deletions.
4 changes: 2 additions & 2 deletions .github/workflows/ci.yml
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ on:
- '!v*-rc*'

concurrency:
group: ${{ github.workflow }}
group: run-only-one-workflow

jobs:
build:
Expand Down Expand Up @@ -52,7 +52,7 @@ jobs:
DTS_VER_ACTUAL="v$(cat meta-dts/meta-dts-distro/conf/distro/dts-distro.conf | grep DISTRO_VERSION | tr -d "\" [A-Z]_=")"
if [ "${DTS_VER_EXPECTED}" != "${DTS_VER_ACTUAL}" ]; then
echo "Tag (${DTS_VER_EXPECTED}) does not match version (${DTS_VER_ACTUAL}) in `meta-dts/meta-dts-distro/conf/distro/dts-distro.conf`"
echo "Tag (${DTS_VER_EXPECTED}) does not match version (${DTS_VER_ACTUAL}) in 'meta-dts/meta-dts-distro/conf/distro/dts-distro.conf'"
exit 1
fi
- name: Deploy DTS on boot.dasharo.com
Expand Down
4 changes: 2 additions & 2 deletions .github/workflows/develop.yml
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ on:
- 'v*-rc*'

concurrency:
group: ${{ github.workflow }}
group: run-only-one-workflow

jobs:
build:
Expand Down Expand Up @@ -51,7 +51,7 @@ jobs:
DTS_VER_ACTUAL="v$(cat meta-dts/meta-dts-distro/conf/distro/dts-distro.conf | grep DISTRO_VERSION | tr -d "\" [A-Z]_=")"
if [ "${DTS_VER_EXPECTED}" != "${DTS_VER_ACTUAL}" ]; then
echo "Tag (${DTS_VER_EXPECTED}) does not match version (${DTS_VER_ACTUAL}) in `meta-dts/meta-dts-distro/conf/distro/dts-distro.conf`"
echo "Tag (${DTS_VER_EXPECTED}) does not match version (${DTS_VER_ACTUAL}) in 'meta-dts/meta-dts-distro/conf/distro/dts-distro.conf'"
exit 1
fi
- name: Deploy DTS on boot.dasharo.com
Expand Down
7 changes: 6 additions & 1 deletion .github/workflows/test.yml
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ on:
- "main"

concurrency:
group: ${{ github.workflow }}
group: run-only-one-workflow

jobs:
build-dts:
Expand Down Expand Up @@ -74,6 +74,11 @@ jobs:
dpp_logs_key: $PCENGINES_LOGS
log_file: output_pcengines_seabios.log

- test: odroid_dpp
dpp_download_key: $ODROID_DOWNLOAD
dpp_logs_key: $ODROID_LOGS
log_file: output_odroid_dpp.log

steps:
- name: Run IPXE server
shell: bash
Expand Down
2 changes: 1 addition & 1 deletion .github/workflows/weekly.yml
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ on:
workflow_dispatch:

concurrency:
group: ${{ github.workflow }}
group: run-only-one-workflow

jobs:
build:
Expand Down
13 changes: 13 additions & 0 deletions CHANGELOG.md
Original file line number Diff line number Diff line change
Expand Up @@ -4,6 +4,19 @@ All notable changes to this project will be documented in this file.

The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/).

## 2.2.1 - 2025-02-05

### Changed
- generate-changelog.sh: Add help and remove container after use
- workflow: change backticks to quotes
- dts-distro.conf: bump version to 2.2.1


### Fixed
- dts-scripts: fixes failed update when FD/ME is locked on e.g. MSI
- dts-scripts: fix ODROID-H4 firmware link and initial deployment


## 2.2.0 - 2025-01-30

### Added
Expand Down
2 changes: 1 addition & 1 deletion meta-dts-distro/conf/distro/dts-distro.conf
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ DISTRO = "dts-distro"

# distro name
DISTRO_NAME = "Dasharo Tools Suite"
DISTRO_VERSION = "2.2.0"
DISTRO_VERSION = "2.2.1"
SDK_VENDOR = "-dtssdk"

MAINTAINER = "3mdeb Sp. z o. o. <contact@3mdeb.com>"
Expand Down
2 changes: 1 addition & 1 deletion meta-dts-distro/recipes-dts/dts-scripts/dts-scripts_git.bb
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSES/Apache-2.0.txt;md5=c846ebb396f8b174b10ded477
PV = "0.1+git${SRCPV}"

SRC_URI = "git://github.com/Dasharo/dts-scripts;protocol=https;branch=main"
SRCREV = "ec37de3da5981106193ab63de226cbb3fdaae394"
SRCREV = "3f59938c9a9de549fe6830a75925534f68373314"

S = "${WORKDIR}/git"

Expand Down
26 changes: 24 additions & 2 deletions scripts/generate-changelog.sh
Original file line number Diff line number Diff line change
@@ -1,12 +1,34 @@
#!/bin/bash

print_usage() {
cat <<EOF
Usage: $(basename "$0") [GITHUB_TOKEN]
Update CHANGELOG.md so it contains all changes between previous release up to
current commit.
If you encounter API request limit errors when generating changelog you can
pass optional GITHUB_TOKEN argument containing your GitHub token which will
increase those limits.
EOF
}

if [ $# -gt 1 ]; then
print_usage
exit 1
fi

if [ "$1" == "-h" ] || [ "$1" == "--help" ]; then
print_usage
exit 0
fi

REPO_DIR=$(git rev-parse --show-toplevel)
RELEASE=v$(grep '^DISTRO_VERSION ' "$REPO_DIR/meta-dts-distro/conf/distro/dts-distro.conf" | cut -d'=' -f2 | tr -d ' "')

if [ $# -eq 1 ]; then
docker run -t -v "$REPO_DIR":/app/ "orhunp/git-cliff:${TAG:-latest}" \
docker run -t --rm -v "$REPO_DIR":/app/ "orhunp/git-cliff:${TAG:-latest}" \
--prepend CHANGELOG.md --unreleased --tag "$RELEASE" --github-token "$1"
else
docker run -t -v "$REPO_DIR":/app/ "orhunp/git-cliff:${TAG:-latest}" \
docker run -t --rm -v "$REPO_DIR":/app/ "orhunp/git-cliff:${TAG:-latest}" \
--prepend CHANGELOG.md --unreleased --tag "$RELEASE"
fi

0 comments on commit 16d4fa0

Please sign in to comment.