-
Notifications
You must be signed in to change notification settings - Fork 6
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
1 parent
128b341
commit b95241d
Showing
1 changed file
with
256 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,256 @@ | ||
#!/SBUILD ver @v1.0.0 | ||
#SELF: https://raw.githubusercontent.com/pkgforge/soarpkgs/refs/heads/main/packages/git/runimage.alpine.stable.yaml | ||
_disabled: false | ||
|
||
pkg: "git" | ||
pkg_id: "runimage.alpine.git" | ||
pkg_type: "runimage" | ||
category: | ||
- "Utility" | ||
description: "Fast, scalable, distributed revision control system" | ||
distro_pkg: | ||
alpine: | ||
- "git" | ||
archlinux: | ||
aur: | ||
- "git-git" | ||
extra: | ||
- "git" | ||
debian: | ||
- "git" | ||
gnuguix: | ||
- "git" | ||
homebrew: | ||
- "git" | ||
nixpkgs: | ||
- "git" | ||
homepage: | ||
- "https://git-scm.com/" | ||
license: | ||
- id : "GPL-2.0" | ||
url: "https://github.com/git/git/raw/5f8f7081f7761acdf83d0a4c6819fe3d724f01d7/COPYING" | ||
maintainer: | ||
- "Azathothas (https://github.com/Azathothas)" | ||
note: | ||
- "[DO NOT RUN] (Meant for pkgforge CI Only)" | ||
- "Built Using RunImage [alpine]. Check/Report @ https://github.com/VHSgunzo/runimage" | ||
- "Learn more @ https://docs.pkgforge.dev/formats/packages/runimage" | ||
- "[PORTABLE] (Works on AnyLinux)" | ||
- "[NO_DESKTOP_INTEGRATION] (Does not need desktop integration)" | ||
provides: | ||
- "git==git-add" | ||
- "git==git-am" | ||
- "git==git-annotate" | ||
- "git==git-apply" | ||
- "git==git-archive" | ||
- "git==git-bisect" | ||
- "git==git-blame" | ||
- "git==git-branch" | ||
- "git==git-bugreport" | ||
- "git==git-bundle" | ||
- "git==git-cat-file" | ||
- "git==git-check-attr" | ||
- "git==git-check-ignore" | ||
- "git==git-check-mailmap" | ||
- "git==git-checkout" | ||
- "git==git-checkout-index" | ||
- "git==git-checkout--worker" | ||
- "git==git-check-ref-format" | ||
- "git==git-cherry" | ||
- "git==git-cherry-pick" | ||
- "git==git-clean" | ||
- "git==git-clone" | ||
- "git==git-column" | ||
- "git==git-commit" | ||
- "git==git-commit-graph" | ||
- "git==git-commit-tree" | ||
- "git==git-config" | ||
- "git==git-count-objects" | ||
- "git==git-credential" | ||
- "git==git-credential-cache" | ||
- "git==git-credential-cache--daemon" | ||
- "git==git-credential-store" | ||
- "git==git-describe" | ||
- "git==git-diagnose" | ||
- "git==git-diff" | ||
- "git==git-diff-files" | ||
- "git==git-diff-index" | ||
- "git==git-difftool" | ||
- "git==git-difftool--helper" | ||
- "git==git-diff-tree" | ||
- "git==git-fast-export" | ||
- "git==git-fetch" | ||
- "git==git-fetch-pack" | ||
- "git==git-filter-branch" | ||
- "git==git-fmt-merge-msg" | ||
- "git==git-for-each-ref" | ||
- "git==git-for-each-repo" | ||
- "git==git-format-patch" | ||
- "git==git-fsck" | ||
- "git==git-fsck-objects" | ||
- "git==git-fsmonitor--daemon" | ||
- "git==git-gc" | ||
- "git==git-get-tar-commit-id" | ||
- "git==git-grep" | ||
- "git==git-hash-object" | ||
- "git==git-help" | ||
- "git==git-hook" | ||
- "git==git-http-fetch" | ||
- "git==git-http-push" | ||
- "git==git-index-pack" | ||
- "git==git-init" | ||
- "git==git-init-db" | ||
- "git==git-interpret-trailers" | ||
- "git==git-log" | ||
- "git==git-ls-files" | ||
- "git==git-ls-remote" | ||
- "git==git-ls-tree" | ||
- "git==git-mailinfo" | ||
- "git==git-mailsplit" | ||
- "git==git-maintenance" | ||
- "git==git-merge" | ||
- "git==git-merge-base" | ||
- "git==git-merge-file" | ||
- "git==git-merge-index" | ||
- "git==git-merge-octopus" | ||
- "git==git-merge-one-file" | ||
- "git==git-merge-ours" | ||
- "git==git-merge-recursive" | ||
- "git==git-merge-resolve" | ||
- "git==git-merge-subtree" | ||
- "git==git-mergetool" | ||
- "git==git-mergetool--lib" | ||
- "git==git-merge-tree" | ||
- "git==git-mktag" | ||
- "git==git-mktree" | ||
- "git==git-multi-pack-index" | ||
- "git==git-mv" | ||
- "git==git-name-rev" | ||
- "git==git-notes" | ||
- "git==git-pack-objects" | ||
- "git==git-pack-redundant" | ||
- "git==git-pack-refs" | ||
- "git==git-patch-id" | ||
- "git==git-prune" | ||
- "git==git-prune-packed" | ||
- "git==git-pull" | ||
- "git==git-push" | ||
- "git==git-quiltimport" | ||
- "git==git-range-diff" | ||
- "git==git-read-tree" | ||
- "git==git-rebase" | ||
- "git==git-receive-pack" | ||
- "git==git-reflog" | ||
- "git==git-refs" | ||
- "git==git-remote" | ||
- "git==git-remote-ext" | ||
- "git==git-remote-fd" | ||
- "git==git-remote-ftp" | ||
- "git==git-remote-ftps" | ||
- "git==git-remote-http" | ||
- "git==git-remote-https" | ||
- "git==git-repack" | ||
- "git==git-replace" | ||
- "git==git-replay" | ||
- "git==git-request-pull" | ||
- "git==git-rerere" | ||
- "git==git-reset" | ||
- "git==git-restore" | ||
- "git==git-revert" | ||
- "git==git-rev-list" | ||
- "git==git-rev-parse" | ||
- "git==git-rm" | ||
- "git==git-send-pack" | ||
- "git==git-shell" | ||
- "git==git-sh-i18n" | ||
- "git==git-sh-i18n--envsubst" | ||
- "git==git-shortlog" | ||
- "git==git-show" | ||
- "git==git-show-branch" | ||
- "git==git-show-index" | ||
- "git==git-show-ref" | ||
- "git==git-sh-setup" | ||
- "git==git-sparse-checkout" | ||
- "git==git-stage" | ||
- "git==git-stash" | ||
- "git==git-status" | ||
- "git==git-stripspace" | ||
- "git==git-submodule" | ||
- "git==git-submodule--helper" | ||
- "git==git-switch" | ||
- "git==git-symbolic-ref" | ||
- "git==git-tag" | ||
- "git==git-unpack-file" | ||
- "git==git-unpack-objects" | ||
- "git==git-update-index" | ||
- "git==git-update-ref" | ||
- "git==git-update-server-info" | ||
- "git==git-upload-archive" | ||
- "git==git-upload-pack" | ||
- "git==git-var" | ||
- "git==git-verify-commit" | ||
- "git==git-verify-pack" | ||
- "git==git-verify-tag" | ||
- "git==git-version" | ||
- "git==git-web--browse" | ||
- "git==git-whatchanged" | ||
- "git==git-worktree" | ||
- "git==git-write-tree" | ||
repology: | ||
- "git" | ||
src_url: | ||
- "https://github.com/git/git" | ||
tag: | ||
- "scm" | ||
- "vcs" | ||
- "version-control" | ||
x_exec: | ||
host: | ||
- "aarch64-Linux" | ||
- "x86_64-Linux" | ||
shell: "bash" | ||
pkgver: | | ||
curl -qfsSL "https://gitlab.alpinelinux.org/alpine/aports/-/raw/master/main/git/APKBUILD" | sed -n 's/^pkgver=//p' | tr -d '[:space:]' | ||
run: | | ||
#Get BaseImage | ||
curl -qfsSL "https://github.com/pkgforge-dev/runimage-base/releases/download/alpine_$(uname -m)/runimage" -o "${SBUILD_TMPDIR}/runimage" | ||
chmod -v 'a+x' "${SBUILD_TMPDIR}/runimage" | ||
[[ -s "${SBUILD_TMPDIR}/runimage" ]] || exit 1 | ||
#Deps | ||
build_image() | ||
{ | ||
#BASE_PKGS=() | ||
apk update --force-missing-repositories --no-cache --no-interactive | ||
apk upgrade --force-missing-repositories --no-cache --no-interactive | ||
#for pkg in "${BASE_PKGS[@]}"; do apk add "${pkg}" --latest --upgrade --no-interactive 2>/dev/null; done | ||
#Main Package | ||
apk add "git" --force-missing-repositories --latest --upgrade --no-cache --no-interactive | ||
command -v "git" >/dev/null 2>&1 || exit 1 | ||
#Debloat & Shrink | ||
apk info -L "git" | ||
rm -rvf "/etc/apk/repositories" 2>/dev/null | ||
rm -rfv "/var/cache/apk/"* 2>/dev/null | ||
rm -rfv "/usr/share/doc/"* 2>/dev/null | ||
rm -rfv "/usr/share/help/"* 2>/dev/null | ||
rm -rfv "/usr/share/kde4/help"* 2>/dev/null | ||
rm -rfv "/usr/share/fonts/"* 2>/dev/null | ||
rm -rfv "/usr/share/licenses/"* 2>/dev/null | ||
rm -rfv "/usr/share/man/"* 2>/dev/null | ||
apk cache clean | ||
ln -sf "/dev/null" "/etc/apk/cache" | ||
rim-shrink --all --verbose 2>/dev/null | ||
#Config | ||
echo 'RIM_AUTORUN="${RIM_AUTORUN:=git}"' > "${RUNDIR}/config/Run.rcfg" | ||
echo 'RIM_CMPRS_LVL="${RIM_CMPRS_LVL:=22}"' >> "${RUNDIR}/config/Run.rcfg" | ||
echo 'RIM_CMPRS_BSIZE="${RIM_CMPRS_BSIZE:=24}"' >> "${RUNDIR}/config/Run.rcfg" | ||
echo 'RIM_SHARE_ICONS="${RIM_SHARE_ICONS:=1}"' >> "${RUNDIR}/config/Run.rcfg" | ||
echo 'RIM_SHARE_FONTS="${RIM_SHARE_FONTS:=1}"' >> "${RUNDIR}/config/Run.rcfg" | ||
echo 'RIM_SHARE_THEMES="${RIM_SHARE_THEMES:=1}"' >> "${RUNDIR}/config/Run.rcfg" | ||
echo 'RIM_SYS_NVLIBS="${RIM_SYS_NVLIBS:=1}"' >> "${RUNDIR}/config/Run.rcfg" | ||
#Rebuild [Dwarfs ZSTD 22] | ||
rim-build --bsize '24' --clvl '22' --dwfs "${SBUILD_OUTDIR}/${PKG}" | ||
} | ||
export -f build_image | ||
#Build | ||
RIM_NO_NVIDIA_CHECK="1" RIM_OVERFS_MODE="1" RIM_ROOT="1" RIM_UNSHARE_USERS="1" \ | ||
"${SBUILD_TMPDIR}/runimage" bash -c "build_image" |