diff --git a/.gitignore b/.gitignore
new file mode 100644
index 00000000..6364b8e6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+
+forkapp/forkapp
+tools/forkapp
diff --git a/applications/luci-app-typecho/Makefile b/applications/luci-app-typecho/Makefile
new file mode 100644
index 00000000..cd0b4532
--- /dev/null
+++ b/applications/luci-app-typecho/Makefile
@@ -0,0 +1,18 @@
+
+
+include $(TOPDIR)/rules.mk
+
+PKG_VERSION:=1.0.2-20231208
+PKG_RELEASE:=
+
+LUCI_TITLE:=LuCI support for TypeCho
+LUCI_PKGARCH:=all
+LUCI_DEPENDS:=+lsblk +docker +luci-lib-taskd +luci-lib-docker
+
+define Package/luci-app-typecho/conffiles
+/etc/config/typecho
+endef
+
+include $(TOPDIR)/feeds/luci/luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-typecho/luasrc/controller/typecho.lua b/applications/luci-app-typecho/luasrc/controller/typecho.lua
new file mode 100755
index 00000000..4bfbce9b
--- /dev/null
+++ b/applications/luci-app-typecho/luasrc/controller/typecho.lua
@@ -0,0 +1,7 @@
+
+module("luci.controller.typecho", package.seeall)
+
+function index()
+ entry({"admin", "services", "typecho"}, alias("admin", "services", "typecho", "config"), _("TypeCho"), 30).dependent = true
+ entry({"admin", "services", "typecho", "config"}, cbi("typecho"))
+end
diff --git a/applications/luci-app-typecho/luasrc/model/cbi/typecho.lua b/applications/luci-app-typecho/luasrc/model/cbi/typecho.lua
new file mode 100644
index 00000000..910ee9aa
--- /dev/null
+++ b/applications/luci-app-typecho/luasrc/model/cbi/typecho.lua
@@ -0,0 +1,60 @@
+--[[
+LuCI - Lua Configuration Interface
+]]--
+
+local taskd = require "luci.model.tasks"
+local docker = require "luci.docker"
+local typecho_model = require "luci.model.typecho"
+local m, s, o
+
+m = taskd.docker_map("typecho", "typecho", "/usr/libexec/istorec/typecho.sh",
+ translate("TypeCho"),
+ translate("TypeCho is an streaming media service and a client–server media player platform, made by TypeCho, Inc.")
+ .. translate("Official website:") .. ' https://www.typecho.tv/')
+
+local dk = docker.new({socket_path="/var/run/docker.sock"})
+local dockerd_running = dk:_ping().code == 200
+local docker_info = dockerd_running and dk:info().body or {}
+local docker_aspace = 0
+if docker_info.DockerRootDir then
+ local statvfs = nixio.fs.statvfs(docker_info.DockerRootDir)
+ docker_aspace = statvfs and (statvfs.bavail * statvfs.bsize) or 0
+end
+
+s = m:section(SimpleSection, translate("Service Status"), translate("TypeCho status:"))
+s:append(Template("typecho/status"))
+
+s = m:section(TypedSection, "main", translate("Setup"),
+ (docker_aspace < 2147483648 and
+ (translate("The free space of Docker is less than 2GB, which may cause the installation to fail.")
+ .. "
") or "") .. translate("The following parameters will only take effect during installation or upgrade:"))
+s.addremove=false
+s.anonymous=true
+
+o = s:option(Value, "port", translate("Port").."*")
+o.default = "9080"
+o.datatype = "port"
+o:depends("hostnet", 0)
+
+o = s:option(Value, "image_name", translate("Image").."*")
+o.rmempty = false
+o.datatype = "string"
+o.default = "joyqi/typecho:nightly-php7.4"
+--if "x86_64" == docker_info.Architecture then
+--end
+o:value("joyqi/typecho:nightly-php7.4", "joyqi/typecho:nightly-php7.4")
+
+local blocks = typecho_model.blocks()
+local home = typecho_model.home()
+
+o = s:option(Value, "config_path", translate("Config path").."*")
+o.rmempty = false
+o.datatype = "string"
+
+local paths, default_path = typecho_model.find_paths(blocks, home, "Configs")
+for _, val in pairs(paths) do
+ o:value(val, val)
+end
+o.default = default_path
+
+return m
diff --git a/applications/luci-app-typecho/luasrc/model/typecho.lua b/applications/luci-app-typecho/luasrc/model/typecho.lua
new file mode 100644
index 00000000..420c8643
--- /dev/null
+++ b/applications/luci-app-typecho/luasrc/model/typecho.lua
@@ -0,0 +1,55 @@
+local util = require "luci.util"
+local jsonc = require "luci.jsonc"
+
+local typecho = {}
+
+typecho.blocks = function()
+ local f = io.popen("lsblk -s -f -b -o NAME,FSSIZE,MOUNTPOINT --json", "r")
+ local vals = {}
+ if f then
+ local ret = f:read("*all")
+ f:close()
+ local obj = jsonc.parse(ret)
+ for _, val in pairs(obj["blockdevices"]) do
+ local fsize = val["fssize"]
+ if fsize ~= nil and string.len(fsize) > 10 and val["mountpoint"] then
+ -- fsize > 1G
+ vals[#vals+1] = val["mountpoint"]
+ end
+ end
+ end
+ return vals
+end
+
+typecho.home = function()
+ local uci = require "luci.model.uci".cursor()
+ local home_dirs = {}
+ home_dirs["main_dir"] = uci:get_first("quickstart", "main", "main_dir", "/root")
+ home_dirs["Configs"] = uci:get_first("quickstart", "main", "conf_dir", home_dirs["main_dir"].."/Configs")
+ home_dirs["Public"] = uci:get_first("quickstart", "main", "pub_dir", home_dirs["main_dir"].."/Public")
+ home_dirs["Downloads"] = uci:get_first("quickstart", "main", "dl_dir", home_dirs["Public"].."/Downloads")
+ home_dirs["Caches"] = uci:get_first("quickstart", "main", "tmp_dir", home_dirs["main_dir"].."/Caches")
+ return home_dirs
+end
+
+typecho.find_paths = function(blocks, home_dirs, path_name)
+ local default_path = ''
+ local configs = {}
+
+ default_path = home_dirs[path_name] .. "/TypeCho"
+ if #blocks == 0 then
+ table.insert(configs, default_path)
+ else
+ for _, val in pairs(blocks) do
+ table.insert(configs, val .. "/" .. path_name .. "/TypeCho")
+ end
+ local without_conf_dir = "/root/" .. path_name .. "/TypeCho"
+ if default_path == without_conf_dir then
+ default_path = configs[1]
+ end
+ end
+
+ return configs, default_path
+end
+
+return typecho
diff --git a/applications/luci-app-typecho/luasrc/view/typecho/status.htm b/applications/luci-app-typecho/luasrc/view/typecho/status.htm
new file mode 100644
index 00000000..80a62e07
--- /dev/null
+++ b/applications/luci-app-typecho/luasrc/view/typecho/status.htm
@@ -0,0 +1,31 @@
+<%
+local util = require "luci.util"
+local container_status = util.trim(util.exec("/usr/libexec/istorec/typecho.sh status"))
+local container_install = (string.len(container_status) > 0)
+local container_running = container_status == "running"
+-%>
+