Skip to content

Commit

Permalink
ath11k-firmware: add wifi firmware for QCN6122
Browse files Browse the repository at this point in the history
Add ability to download and package ath11k firmware for QCN6122.
While at it, add support for packaging BDFs for QCN6122 wifi and
update iwinfo to recognize QCN6122 wifi.

Signed-off-by: George Moussalem <george.moussalem@outlook.com>
  • Loading branch information
georgemoussalem committed Oct 8, 2024
1 parent 42b0627 commit 5763112
Show file tree
Hide file tree
Showing 3 changed files with 26 additions and 1 deletion.
13 changes: 13 additions & 0 deletions package/firmware/ath11k-firmware/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -47,6 +47,11 @@ $(Package/ath11k-firmware-default)
TITLE:=IPQ8074 ath11k firmware
endef

define Package/ath11k-firmware-qcn6122
$(Package/ath11k-firmware-default)
TITLE:=QCN6122 ath11k firmware
endef

define Package/ath11k-firmware-qcn9074
$(Package/ath11k-firmware-default)
TITLE:=QCN9074 ath11k firmware
Expand Down Expand Up @@ -88,6 +93,13 @@ define Package/ath11k-firmware-ipq8074/install
$(1)/lib/firmware/IPQ8074/
endef

define Package/ath11k-firmware-qcn6122/install
$(INSTALL_DIR) $(1)/lib/firmware/ath11k/qcn6122/hw1.0
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/ath11k-firmware/IPQ5018_QCN6122_QCN6122/hw1.0/2.7.0.1/WLAN.HK.2.7.0.1-01744-QCAHKSWPL_SILICONZ-1/qcn6122/* \
$(1)/lib/firmware/ath11k/qcn6122/hw1.0/
endef

define Package/ath11k-firmware-qcn9074/install
$(INSTALL_DIR) $(1)/lib/firmware/ath11k/QCN9074/hw1.0
$(INSTALL_DATA) \
Expand All @@ -100,4 +112,5 @@ endef
$(eval $(call BuildPackage,ath11k-firmware-ipq5018))
$(eval $(call BuildPackage,ath11k-firmware-ipq6018))
$(eval $(call BuildPackage,ath11k-firmware-ipq8074))
$(eval $(call BuildPackage,ath11k-firmware-qcn6122))
$(eval $(call BuildPackage,ath11k-firmware-qcn9074))
4 changes: 3 additions & 1 deletion package/firmware/ipq-wifi/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -102,10 +102,12 @@ define ipq-wifi-install-one
$(call ipq-wifi-install-ath11-one-to,$(1),$(2),IPQ6018/hw1.0),\
$(if $(filter $(suffix $(1)),.IPQ8074 .ipq8074),\
$(call ipq-wifi-install-ath11-one-to,$(1),$(2),IPQ8074/hw2.0),\
$(if $(filter $(suffix $(1)),.QCN6122 .qcn6122),\
$(call ipq-wifi-install-ath11-one-to,$(1),$(2),qcn6122/hw1.0),\
$(if $(filter $(suffix $(1)),.QCN9074 .qcn9074),\
$(call ipq-wifi-install-ath11-one-to,$(1),$(2),QCN9074/hw1.0),\
$(error Unrecognized board-file suffix '$(suffix $(1))' for '$(1)')\
)))))))))
))))))))))

endef
# Blank line required at end of above define due to foreach context
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
--- a/devices.txt
+++ b/devices.txt
@@ -255,6 +255,7 @@
"qcom,ipq5018-wifi" 0 0 "Qualcomm Atheros" "IPQ5018"
"qcom,ipq6018-wifi" 0 0 "Qualcomm Atheros" "IPQ6018"
"qcom,ipq8074-wifi" 0 0 "Qualcomm Atheros" "IPQ8074"
+"qcom,qcn6122-wifi" 0 0 "Qualcomm Atheros" "QCN6102/6122"
"mediatek,mt7622-wmac" 0 0 "MediaTek" "MT7622"
"mediatek,mt7628-wmac" 0 0 "MediaTek" "MT7628"
"mediatek,mt7981-wmac" 0 0 "MediaTek" "MT7981"

0 comments on commit 5763112

Please sign in to comment.