Skip to content

Commit

Permalink
Add package 'libnghttp2' to the set of ABS packages
Browse files Browse the repository at this point in the history
  • Loading branch information
ezamlinsky committed Jul 13, 2019
1 parent 0221e3c commit 6647382
Showing 1 changed file with 123 additions and 0 deletions.
123 changes: 123 additions & 0 deletions libnghttp2/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,123 @@
################################################################################
# Encoding: UTF-8 Tab size: 4 #
# #
# ARCH LINUX PACKAGE BUILD DESCRIPTION FILE #
# #
# Ordnung muss sein! Copyleft (Ɔ) 2019, Arch Linux #
################################################################################
# Maintainer: Jack Black <ezamlinsky@gmail.com>

#==============================================================================#
# Package information #
#==============================================================================#
pkgname=('libnghttp2')
pkgver=1.39.1
pkgrel=1
pkgdesc='Framing layer of HTTP/2 is implemented as a reusable C library'
url='https://nghttp2.org/'
license=('MIT')
arch=('x86_64')

#==============================================================================#
# Package dependencies #
#==============================================================================#
depends=('glibc')

#==============================================================================#
# Package relations #
#==============================================================================#
conflicts=('nghttp2<1.20.0-2')

#==============================================================================#
# Package sources and integrity #
#==============================================================================#
source=("https://github.com/nghttp2/nghttp2/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz")
sha512sums=('36558ed03c59086086abbf144ec7c54c60de3fea00a9ea594feea7186a779781cbb66a08c9b34265892dea382b42b875f551e85331cfa0086e357f9b27b919fa')

#==============================================================================#
# Package preparation sequence #
#==============================================================================#
prepare() {

# Change directory to source directory
cd nghttp2-$pkgver

# Run autogen script if exists
if [ -x autogen.sh ]; then
NOCONFIGURE=1 ./autogen.sh
fi
}

#==============================================================================#
# Package building sequence #
#==============================================================================#
build() {

# Change directory to source directory
cd nghttp2-$pkgver

# Default configure options
config_opts=(
'--prefix=/usr'
'--bindir=/usr/bin'
'--sbindir=/usr/bin'
'--libdir=/usr/lib'
'--libexecdir=/usr/lib'
'--sysconfdir=/etc'
'--localstatedir=/var'
'--enable-silent-rules'
'--enable-shared'
'--disable-static'
'--disable-debug'
'--disable-examples'
'--disable-assert'
'--enable-threads'
'--enable-lib-only'
'--with-libxml2'
'--with-jemalloc'
'--with-systemd'
'--with-boost=yes'
)

# Run package configuration script
./configure "${config_opts[@]}"

# Set correct LDFLAGS to build a shared archive
if [ -f libtool ]; then
sed -e "s/ -shared / $LDFLAGS\0/g" -i libtool
fi

# Build package
make
}

#==============================================================================#
# Package self testing sequence #
#==============================================================================#
check() {

# Change directory to source directory
cd nghttp2-$pkgver

# Run internal checks
make -k check
}

#==============================================================================#
# Package installation sequence #
#==============================================================================#
package() {

# Change directory to source directory
cd nghttp2-$pkgver/lib

# Install files
make DESTDIR=$pkgdir install

# Install license file
install -Dm644 ../COPYING $pkgdir/usr/share/licenses/libnghttp2/COPYING
}

################################################################################
# END OF FILE #
################################################################################

0 comments on commit 6647382

Please sign in to comment.