API Changes with New Naming Convention
So, for a while I've known I would need to change the 'opt' prefix naming convention to a suffix. This is because the prefix naming convention is ambiguous when you have a sequence that is either itself optional or contains optional items.
So I've gone through the code and made this change. Obviously, this creates a lot of breakage in the API, and may affect your serialized data if it uses properties with the previous naming convention.
Apologies if this is an inconvenience - the semantics of the previous convention were too ambiguous and broken to not address.