Skip to content

Commit

Permalink
Merge branch 'main' of github.com:openwrt/openwrt into bananapi4
Browse files Browse the repository at this point in the history
  • Loading branch information
N-Storm committed Nov 7, 2024
2 parents 24eb24d + 6691ff8 commit b4bfe92
Show file tree
Hide file tree
Showing 8 changed files with 94 additions and 113 deletions.
6 changes: 3 additions & 3 deletions package/kernel/r8125/Makefile
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=r8125
PKG_VERSION:=9.013.02
PKG_RELEASE:=4
PKG_VERSION:=9.014.01
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://github.com/openwrt/rtl8125/releases/download/$(PKG_VERSION)
PKG_HASH:=d36410ee99c956f250d9cd08340d8c36567d190f420a8ee128ff6e51225aac0c
PKG_HASH:=f006aa95501738ca55c522812c9d1b473ac781675f3ad88ce341a09316b8aa13

PKG_BUILD_PARALLEL:=1
PKG_LICENSE:=GPLv2
Expand Down
26 changes: 0 additions & 26 deletions package/kernel/r8125/patches/100-r8125_rss-silence-rxnfc-log.patch

This file was deleted.

Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>

--- a/src/r8125.h
+++ b/src/r8125.h
@@ -1563,6 +1563,8 @@ enum RTL8125_register_content {
@@ -1672,6 +1672,8 @@ enum RTL8125_register_content {
LinkStatus = 0x02,
FullDup = 0x01,

Expand All @@ -37,7 +37,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
#include <linux/netdevice.h>
#include <linux/etherdevice.h>
#include <linux/delay.h>
@@ -5112,6 +5113,38 @@ rtl8125_link_down_patch(struct net_devic
@@ -5116,6 +5117,38 @@ rtl8125_link_down_patch(struct net_devic
#endif
}

Expand Down Expand Up @@ -74,10 +74,10 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
+}
+
static void
_rtl8125_check_link_status(struct net_device *dev)
_rtl8125_check_link_status(struct net_device *dev, unsigned int link_state)
{
@@ -5120,11 +5153,18 @@ _rtl8125_check_link_status(struct net_de
if (tp->link_ok(dev)) {
@@ -5128,11 +5161,18 @@ _rtl8125_check_link_status(struct net_de
if (link_state == R8125_LINK_STATE_ON) {
rtl8125_link_on_patch(dev);

- if (netif_msg_ifup(tp))
Expand Down
6 changes: 3 additions & 3 deletions package/system/procd/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,9 +12,9 @@ PKG_RELEASE:=1

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
PKG_MIRROR_HASH:=3d15a68fb614c4d7e129dc1bbe8a79adcb3115753c2fc95a36fd03855efc7a58
PKG_SOURCE_DATE:=2024-10-20
PKG_SOURCE_VERSION:=ef3ab8bc8fb18216793dd0c8106dd222c560453a
PKG_MIRROR_HASH:=0f494faf2811af6cd7332acda8049ad9713dcabc4b2885dc14acbd9f61920be1
PKG_SOURCE_DATE:=2024-11-06
PKG_SOURCE_VERSION:=109fa41b2321506280397e03757976c468832668
CMAKE_INSTALL:=1

PKG_LICENSE:=GPL-2.0
Expand Down
140 changes: 70 additions & 70 deletions package/utils/fritz-tools/src/fritz_cal_extract.c
Original file line number Diff line number Diff line change
Expand Up @@ -48,86 +48,86 @@ static inline size_t special_min(size_t a, size_t b)
is an error reading or writing the files. */
static int inf(FILE *source, FILE *dest, size_t limit, size_t skip)
{
int ret;
size_t have;
z_stream strm;
unsigned char in[CHUNK];
unsigned char out[CHUNK];
int ret;
size_t have;
z_stream strm;
unsigned char in[CHUNK];
unsigned char out[CHUNK];

/* allocate inflate state */
strm.zalloc = Z_NULL;
strm.zfree = Z_NULL;
strm.opaque = Z_NULL;
strm.avail_in = 0;
strm.next_in = Z_NULL;
ret = inflateInit(&strm);
if (ret != Z_OK)
return ret;
/* allocate inflate state */
strm.zalloc = Z_NULL;
strm.zfree = Z_NULL;
strm.opaque = Z_NULL;
strm.avail_in = 0;
strm.next_in = Z_NULL;
ret = inflateInit(&strm);
if (ret != Z_OK)
return ret;

/* decompress until deflate stream ends or end of file */
do {
strm.avail_in = fread(in, 1, CHUNK, source);
if (ferror(source)) {
(void)inflateEnd(&strm);
return Z_ERRNO;
}
if (strm.avail_in == 0)
break;
strm.next_in = in;
/* decompress until deflate stream ends or end of file */
do {
strm.avail_in = fread(in, 1, CHUNK, source);
if (ferror(source)) {
(void)inflateEnd(&strm);
return Z_ERRNO;
}
if (strm.avail_in == 0)
break;
strm.next_in = in;

/* run inflate() on input until output buffer not full */
do {
strm.avail_out = CHUNK;
strm.next_out = out;
ret = inflate(&strm, Z_NO_FLUSH);
assert(ret != Z_STREAM_ERROR); /* state not clobbered */
switch (ret) {
case Z_NEED_DICT:
ret = Z_DATA_ERROR; /* and fall through */
case Z_DATA_ERROR:
case Z_MEM_ERROR:
(void)inflateEnd(&strm);
return ret;
}
have = special_min(limit, CHUNK - strm.avail_out) - skip;
if (fwrite(&out[skip], have, 1, dest) != 1 || ferror(dest)) {
(void)inflateEnd(&strm);
return Z_ERRNO;
}
skip = 0;
limit -= have;
} while (strm.avail_out == 0 && limit > 0);
/* run inflate() on input until output buffer not full */
do {
strm.avail_out = CHUNK;
strm.next_out = out;
ret = inflate(&strm, Z_NO_FLUSH);
assert(ret != Z_STREAM_ERROR); /* state not clobbered */
switch (ret) {
case Z_NEED_DICT:
ret = Z_DATA_ERROR; /* and fall through */
case Z_DATA_ERROR:
case Z_MEM_ERROR:
(void)inflateEnd(&strm);
return ret;
}
have = special_min(limit, CHUNK - strm.avail_out) - skip;
if (fwrite(&out[skip], have, 1, dest) != 1 || ferror(dest)) {
(void)inflateEnd(&strm);
return Z_ERRNO;
}
skip = 0;
limit -= have;
} while (strm.avail_out == 0 && limit > 0);

/* done when inflate() says it's done */
} while (ret != Z_STREAM_END && limit > 0);
/* done when inflate() says it's done */
} while (ret != Z_STREAM_END && limit > 0);

/* clean up and return */
(void)inflateEnd(&strm);
return (limit == 0 ? Z_OK : (ret == Z_STREAM_END ? Z_OK : Z_DATA_ERROR));
/* clean up and return */
(void)inflateEnd(&strm);
return (limit == 0 ? Z_OK : (ret == Z_STREAM_END ? Z_OK : Z_DATA_ERROR));
}

/* report a zlib or i/o error */
static void zerr(int ret)
{
switch (ret) {
case Z_ERRNO:
if (ferror(stdin))
fputs("error reading stdin\n", stderr);
if (ferror(stdout))
fputs("error writing stdout\n", stderr);
break;
case Z_STREAM_ERROR:
fputs("invalid compression level\n", stderr);
break;
case Z_DATA_ERROR:
fputs("invalid or incomplete deflate data\n", stderr);
break;
case Z_MEM_ERROR:
fputs("out of memory\n", stderr);
break;
case Z_VERSION_ERROR:
fputs("zlib version mismatch!\n", stderr);
}
switch (ret) {
case Z_ERRNO:
if (ferror(stdin))
fputs("error reading stdin\n", stderr);
if (ferror(stdout))
fputs("error writing stdout\n", stderr);
break;
case Z_STREAM_ERROR:
fputs("invalid compression level\n", stderr);
break;
case Z_DATA_ERROR:
fputs("invalid or incomplete deflate data\n", stderr);
break;
case Z_MEM_ERROR:
fputs("out of memory\n", stderr);
break;
case Z_VERSION_ERROR:
fputs("zlib version mismatch!\n", stderr);
}
}

static unsigned int get_num(char *str)
Expand Down
10 changes: 5 additions & 5 deletions target/linux/ath79/dts/qca9558_linksys_ea4500-v3.dts
Original file line number Diff line number Diff line change
Expand Up @@ -123,7 +123,7 @@

partition@2c0000 {
label = "firmware";
reg = <0x2c0000 0x5000000>;
reg = <0x2c0000 0x7d40000>;

compatible = "fixed-partitions";
#address-cells = <1>;
Expand All @@ -136,7 +136,7 @@

partition@400000 {
label = "ubi";
reg = <0x400000 0x4c00000>;
reg = <0x400000 0x7940000>;
};

/* Original layout for secondary partitions */
Expand All @@ -151,11 +151,11 @@
}; */
};

partition@52c0000 {
/* Original layout for user data partition */
/* partition@52c0000 {
label = "syscfg";
reg = <0x52c0000 0x2d40000>;
read-only;
};
}; */
};
};

Expand Down
8 changes: 7 additions & 1 deletion target/linux/ath79/image/nand.mk
Original file line number Diff line number Diff line change
Expand Up @@ -281,14 +281,20 @@ TARGET_DEVICES += glinet_gl-x1200-nor

define Device/linksys_ea4500-v3
SOC := qca9558
DEVICE_COMPAT_VERSION := 1.1
DEVICE_COMPAT_MESSAGE := Partition table has been changed. Please \
install kmod-mtd-rw and erase mtd8 (syscfg) before upgrade \
to keep configures, or forcibly flash factory image to mtd5 \
(firmware) partition with mtd tool to discard configures but \
claim additional space immediately.
DEVICE_VENDOR := Linksys
DEVICE_MODEL := EA4500
DEVICE_VARIANT := v3
DEVICE_PACKAGES := kmod-usb2
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_SIZE := 4096k
IMAGE_SIZE := 81920k
IMAGE_SIZE := 128256k
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
LINKSYS_HWNAME := EA4500V3
IMAGES += factory.img
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -4,6 +4,7 @@
board_config_update

case "$(board_name)" in
linksys,ea4500-v3|\
netgear,wndr4300-v2|\
netgear,wndr4500-v3)
ucidef_set_compat_version "1.1"
Expand Down

0 comments on commit b4bfe92

Please sign in to comment.